Python 3.6.0 / 2.7  [Resolvido]

Para aqueles que estão iniciando no mundo GNU/Linux, sobretudo no Manjaro Linux.
Regras do fórum Leia as Regras Gerais do Manjaro Brasil em "Normatividade" e pesquise antes de postar.
Se sua dúvida foi respondida, não esqueça de marcar RESOLVIDO em seus tópicos, botão com a marca verde Imagem

Python 3.6.0 / 2.7

Mensagempor marcosfz » 17 Mar 2017, 16:14  •  MS 1

Olá pessoal, sou novo no manjaro é gostaria de substituir a versão do python, estou utilizando a 3.6.0, quero a 2.7, alguém poderia ajudar?
Avatar do usuário
marcosfz
Aprendiz

 
Mensagens: 14
Registro: 14 Mar 2017, 13:29
Agradeceu: 1 vez
Agradecido: 0 vez
Distro utilizada: Gellivara
Versão: 17.0
Ambiente: xfce
Repositório: -
Habilidade: Novice

Python 3.6.0 / 2.7

Mensagempor chmercesmoreira » 17 Mar 2017, 19:05  •  MS 2

A versão 2.7 já vem instalada por padrão:
Código: Selecionar todos
$ ls -la /usr/bin/python*
lrwxrwxrwx 1 root root     7 jan 16 09:14 /usr/bin/python -> python3
lrwxrwxrwx 1 root root     9 dez 21 05:23 /usr/bin/python2 -> python2.7
-rwxr-xr-x 1 root root  6304 dez 21 05:23 /usr/bin/python2.7
-rwxr-xr-x 1 root root  1681 dez 21 05:23 /usr/bin/python2.7-config
lrwxrwxrwx 1 root root    16 dez 21 05:23 /usr/bin/python2-config -> python2.7-config
lrwxrwxrwx 1 root root     9 jan 16 09:14 /usr/bin/python3 -> python3.6
-rwxr-xr-x 2 root root 10392 jan 16 09:14 /usr/bin/python3.6
lrwxrwxrwx 1 root root    17 jan 16 09:14 /usr/bin/python3.6-config -> python3.6m-config
-rwxr-xr-x 2 root root 10392 jan 16 09:14 /usr/bin/python3.6m
-rwxr-xr-x 1 root root  3146 jan 16 09:14 /usr/bin/python3.6m-config
lrwxrwxrwx 1 root root    16 jan 16 09:14 /usr/bin/python3-config -> python3.6-config
lrwxrwxrwx 1 root root    14 jan 16 09:14 /usr/bin/python-config -> python3-config
lrwxrwxrwx 1 root root    52 nov 20 11:50 /usr/bin/pythontex -> /usr/share/texmf-dist/scripts/pythontex/pythontex.py

Código: Selecionar todos
$ python2.7 -V
Python 2.7.13
Imagem Imagem

O Conhecimento é Irresistível
Avatar do usuário
chmercesmoreira
Especial

 
Mensagens: 745
Artigos: 1
Registro: 31 Jan 2016, 10:58
Localização: Rio de Janeiro/RJ
Agradeceu: 14 vez(es)
Agradecido: 213 vez(es)
Distro utilizada: Manjaro
Versão: 16.10
Ambiente: KDE
Repositório: Unstable
Habilidade: Intermediate

Python 3.6.0 / 2.7

Mensagempor marcosfz » 17 Mar 2017, 20:01  •  MS 3

chmercesmoreira escreveu:A versão 2.7 já vem instalada por padrão:
Código: Selecionar todos
$ ls -la /usr/bin/python*
lrwxrwxrwx 1 root root     7 jan 16 09:14 /usr/bin/python -> python3
lrwxrwxrwx 1 root root     9 dez 21 05:23 /usr/bin/python2 -> python2.7
-rwxr-xr-x 1 root root  6304 dez 21 05:23 /usr/bin/python2.7
-rwxr-xr-x 1 root root  1681 dez 21 05:23 /usr/bin/python2.7-config
lrwxrwxrwx 1 root root    16 dez 21 05:23 /usr/bin/python2-config -> python2.7-config
lrwxrwxrwx 1 root root     9 jan 16 09:14 /usr/bin/python3 -> python3.6
-rwxr-xr-x 2 root root 10392 jan 16 09:14 /usr/bin/python3.6
lrwxrwxrwx 1 root root    17 jan 16 09:14 /usr/bin/python3.6-config -> python3.6m-config
-rwxr-xr-x 2 root root 10392 jan 16 09:14 /usr/bin/python3.6m
-rwxr-xr-x 1 root root  3146 jan 16 09:14 /usr/bin/python3.6m-config
lrwxrwxrwx 1 root root    16 jan 16 09:14 /usr/bin/python3-config -> python3.6-config
lrwxrwxrwx 1 root root    14 jan 16 09:14 /usr/bin/python-config -> python3-config
lrwxrwxrwx 1 root root    52 nov 20 11:50 /usr/bin/pythontex -> /usr/share/texmf-dist/scripts/pythontex/pythontex.py

Código: Selecionar todos
$ python2.7 -V
Python 2.7.13

como faço pra executar um programa em python, com a versão 2.7
Avatar do usuário
marcosfz
Aprendiz

 
Mensagens: 14
Registro: 14 Mar 2017, 13:29
Agradeceu: 1 vez
Agradecido: 0 vez
Distro utilizada: Gellivara
Versão: 17.0
Ambiente: xfce
Repositório: -
Habilidade: Novice

Python 3.6.0 / 2.7  [Resolvido]

Mensagempor chmercesmoreira » 17 Mar 2017, 20:35  •  MS 4

Código: Selecionar todos
python2.7 caminhoParaPrograma.py


@edit

Existe esse procedimento também: https://wiki.archlinux.org/index.php/py ... ld_scripts
Ele altera temporariamente a variável de ambiente do sistema que aponta por padrão para a versão 3.* do Python para a versão que você desejar.
Editado pela última vez por chmercesmoreira em 17 Mar 2017, 20:40, em um total de 2 vezes.
Razão: Correção
Imagem Imagem

O Conhecimento é Irresistível
Avatar do usuário
chmercesmoreira
Especial

 
Mensagens: 745
Artigos: 1
Registro: 31 Jan 2016, 10:58
Localização: Rio de Janeiro/RJ
Agradeceu: 14 vez(es)
Agradecido: 213 vez(es)
Distro utilizada: Manjaro
Versão: 16.10
Ambiente: KDE
Repositório: Unstable
Habilidade: Intermediate


Voltar para Iniciante



Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 0 visitantes

^ Voltar ao Topo