LXDM no XFCE  [Resolvido]

Assuntos gerais relacionados ao XFCE, por exemplo, instalação, configuração, personalização, etc.
Regras do fórum Leia as Regras Gerais do Manjaro Brasil em "Normatividade" e pesquise antes de postar.
Se sua dúvida foi respondida, não esqueça de marcar RESOLVIDO em seus tópicos, botão com a marca verde Imagem

LXDM no XFCE

Mensagempor Danipru3 » 03 Dez 2017, 00:49  •  MS 1

Bom dia
Depois das recentes atualizações do manjaro, o mdm parou de funcionar na minha maquina
Estava seguindo a pagina do aur para ver se saía alguma solução mas a que saiu não resolveu para mim
Então resolvi mudar de gerenciador de login e instalei o lxdm (depois de tentar gdm e slim, sem sucesso)
Mas estou com problemas para fazê-lo iniciar (aparecer a tela de login)
Depois do boot, a tela fica preta e só consigo logar se mudar de terminal e logar no console
Parece estar tudo ok conforme as informações abaixo

Código: Selecionar todos
[[email protected] ~]$ systemctl status lxdm
● lxdm.service - LXDE Display Manager
   Loaded: loaded (/usr/lib/systemd/system/lxdm.service; disabled; vendor preset: disabled)
   Active: active (running) since Sun 2017-12-03 01:03:16 -02; 14min ago
 Main PID: 1147 (lxdm-binary)
    Tasks: 4 (limit: 4915)
   CGroup: /system.slice/lxdm.service
           ├─1147 /usr/sbin/lxdm-binary
           └─1149 /usr/lib/xorg-server/Xorg -background none :0 vt01 -nolisten tcp -novtswitch -auth /var/run/lxdm/lxdm-:0.auth

dez 03 01:03:16 Notebook systemd[1]: Started LXDE Display Manager.
dez 03 01:03:39 Notebook lxdm-session[1158]: pam_unix(lxdm:session): session opened for user daniel by (uid=0)
[[email protected] ~]$


[
Código: Selecionar todos
[email protected] ~]$ cat /etc/lxdm/lxdm.conf | grep startxfce4
session=/usr/bin/startxfce4
[[email protected] ~]$


alguem?
Editado pela última vez por Holmes em 03 Dez 2017, 09:11, em um total de 1 vez.
Razão: correções
Avatar do usuário
Danipru3
Aprendiz

 
Mensagens: 46
Registro: 25 Jun 2014, 04:29
Agradeceu: 4 vez(es)
Agradecido: 2 vez(es)
Distro utilizada: Manjaro
Versão: 2014.06.01
Ambiente: XFCE
Repositório: Unstable
Habilidade: Novice

LXDM no XFCE

Mensagempor Holmes » 03 Dez 2017, 09:23  •  MS 2

você ativou o LXDM? assim: sudo systemctl enable lxdm.service e sudo systemctl start lxdm.service.

vlw fwi, Holmes :)
Editado pela última vez por Holmes em 03 Dez 2017, 09:23, em um total de 1 vez.
Razão: correções
Imagem

Meu Blog Kibojoe I Manjaro I JWM I Outras Coisas...

Visitem e colaborem com nosso Knowledge Base
Leia as Regras Gerais e pesquise antes de postar
Se a sua dúvida foi respondida marque Resolvido em seu tópico com o botão V na cor verde
Avatar do usuário
Holmes
Fundador

Mantenedor Kibojoe Linux
Mantenedor Kibojoe Linux
 
Mensagens: 5354
Artigos: 56
Registro: 30 Set 2012, 21:00
Localização: Brasil
Agradeceu: 164 vez(es)
Agradecido: 769 vez(es)
Distro utilizada: Kibojoe
Versão: 17.09rc1
Ambiente: JWM
Repositório: Stable
Habilidade: Intermediate

LXDM no XFCE

Mensagempor Danipru3 » 03 Dez 2017, 12:43  •  MS 3

Holmes escreveu:você ativou o LXDM? assim: sudo systemctl enable lxdm.service e sudo systemctl start lxdm.service.

vlw fwi, Holmes :)


Exatamente

Quando eu logo no console e rodo sudo systemctl start lxdm.service, ele mostra a tela de login mas no boot cai no login via terminal
Editado pela última vez por Danipru3 em 03 Dez 2017, 12:49, em um total de 1 vez.
Razão: inserção de informações
Avatar do usuário
Danipru3
Aprendiz

 
Mensagens: 46
Registro: 25 Jun 2014, 04:29
Agradeceu: 4 vez(es)
Agradecido: 2 vez(es)
Distro utilizada: Manjaro
Versão: 2014.06.01
Ambiente: XFCE
Repositório: Unstable
Habilidade: Novice

LXDM no XFCE

Mensagempor overlock » 03 Dez 2017, 13:10  •  MS 4

Hum,como não nos passou o arquivo completo para analisarmos,veja se o arquivo de configuração está configurardo corretamente >>> https://wiki.archlinux.org/index.php/LXDM <<<
|| Manjaro | Kibojoe | | Linux User # 480186 | :!: Não esqueção do nosso canal no IRC freenode #manjaro-br | Não dou o peixe, ensino a pescar !
Avatar do usuário
overlock
Moderador

 
Mensagens: 396
Registro: 18 Fev 2017, 00:52
Localização: São Paulo
Agradeceu: 3 vez(es)
Agradecido: 60 vez(es)
Distro utilizada: Kibojoe
Versão: 17.09rc3
Ambiente: JWM
Repositório: Stable
Habilidade: Intermediate

LXDM no XFCE  [Resolvido]

Mensagempor Danipru3 » 03 Dez 2017, 17:13  •  MS 5

nao é só alterar a linha do session para /usr/bin/startxfce4?

eu só instalei o lxdm, alterei essa linha e a linha do background (para adicionar uma imagem no background)

mas posso por o arquivo aqui, segue:

Código: Selecionar todos
[base]
## uncomment and set autologin username to enable autologin
# autologin=dgod

## uncomment and set timeout to enable timeout autologin,
## the value should >=5
# timeout=10

## default session or desktop used when no systemwide config
session=/usr/bin/startxfce4

## uncomment and set to set numlock on your keyboard
# numlock=0

## set this if you don't want to put xauth file at ~/.Xauthority
# xauth_path=/tmp

# not ask password for users who have empty password
# skip_password=1

## greeter used to welcome the user
greeter=/usr/lib/lxdm/lxdm-greeter-gtk

[server]
## arg used to start xserver, not fully function
arg=/usr/bin/X -background vt1
# uncomment this if you really want xserver listen to tcp
# tcp_listen=1
# uncoment this if you want reset the xserver after logou
# reset=1

[display]
## gtk theme used by greeter
gtk_theme=Adwaita

## background of the greeter
bg=/home/daniel/Imagens/1354664684.jpg

## if show bottom pane
bottom_pane=1

## if show language select control
lang=1

## if show keyboard layout select control
keyboard=0

## the theme of greeter
theme=Industrial

[input]

[userlist]
## if disable the user list control at greeter
disable=0

## whitelist user
white=

## blacklist user
black=


== Editado em 04 Dez 2017, 21:07 ==

Solução conseguida através da instalação, por indicação, do lightdm
Editado pela última vez por Danipru3 em 04 Dez 2017, 21:07, em um total de 2 vezes.
Razão: Solução
Avatar do usuário
Danipru3
Aprendiz

 
Mensagens: 46
Registro: 25 Jun 2014, 04:29
Agradeceu: 4 vez(es)
Agradecido: 2 vez(es)
Distro utilizada: Manjaro
Versão: 2014.06.01
Ambiente: XFCE
Repositório: Unstable
Habilidade: Novice


Voltar para XFCE



Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 2 visitantes

^ Voltar ao Topo